How to Fix Drifting in Angle / Horizon Mode | Betaflight

Here is a quick guide that might fix drifting issue in Angle mode and Horizon mode in Betaflight.

Scenario: your quad might appear to be stable at first when hovering, but gradually it starts to drift more and more over time and requires constant stick adjustment. Eventually towards the end of the flight it’s drifting so much even full stick deflection is not enough to keep it level.

If you only have drifting in Angle mode and Horizon mode, but not Acro mode, that’s an indication that the problem is caused by the accelerometer (ACC), because Acro mode only uses the Gyro while Angle and Horizon mode uses both Gyro and ACC.

Here is the fix, go to Betaflight CLI, and look for these parameters:

set acc_lpf_hz = 20
set accxy_deadband = 40
set accz_deadband = 40

And change them to:

set acc_lpf_hz = 1
set accxy_deadband = 80
set accz_deadband = 80
save

Drifting in Angle and Horizon mode can be caused by vibration in the quad. The vibration can be very small and overlooked by the pilot, but the sensor can still sense it. It causes the neutral position to slowly drift.

Basically, “acc_lpf_hz” is the low pass filter for ACC data, reducing the value means reducing ACC sensitivity, so it will ignore most of the noise/vibration. It will make your quad less responsive, but it won’t get affected by vibration as bad.

6 thoughts on “How to Fix Drifting in Angle / Horizon Mode | Betaflight

  1. Michael

    I’m having the same trouble with my new Armattan Tadpole build. I set the acc_lpf_hz as shown but the quad still drifts heavily to the right. Eventually becoming too much to correct and i have to disarm.

    It’s also been mentioned that the deadband settings are no longer there.

    Is there any more information about this issue in Betaflight 4.1+

    Reply
  2. Fred Cass / VRMan3D

    My new Matek F722se FC has this problem. I usually take off for the first flight in autolevel mode and with this new board when you arm, it wants to lean a random direction. If I replug the battery with it on a level surface that seems to fix it again.
    I was able to change the lpf hz setting here, but they may have removed the deadband settings in betaflight 4.1.

    I really like having autolevel on a switch for the rare occasion I fly behind something and lose video, I flick level and blast vertical and it can save a quad.

    On the bench it seems just changing the filter is already improving it. (I would go back to the first tab before and it would be sideways, now it’s staying level so it’s probably fixed. Thanks Oscar.

    Reply
  3. Parris

    Thank you , OscarLiang ,
    I just happened to come across this article online and thought I would give it a try on a few Miniquad F3 boards I had shelved two or three ago that had this stated problem . The fix seems to be working . I’m going to mess around with the values a little bit to see which values works best with the airframe set-ups I have on each , but , so far this tip working .

    Thanks ,

    Parris

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

Are you Robot? *

For prompt technical support, please use our forum IntoFPV.com. I check blog comments weekly.