Flashing Betaflight on Moblite6 and 7, Settings You Have to Change

by Oscar
Published: Last Updated on

After flashing Betaflight firmware on Mobilte6 and Mobilte7, you probably find it unable to take off. I don’t think you have to update Betaflight on this tiny quad, but if you have to, here are the settings you need to change to make it fly again.

The Moblite 6 and 7 are great indoor flyers, check out my review here.

Necessary Changes

These are the things you need to change or the quad will just flip over when trying to lift off:

  • Set board and sensor alignment, yaw to 180
  • In configuration tab, enable “Motor direction is reversed”
  • remap motors in CLI (as the board is rotated)

Here’re the command lines you can just copy and paste in CLI:

set align_board_yaw = 180
set yaw_motors_reversed = ON
resource MOTOR 4 B10
resource MOTOR 3 B06
resource MOTOR 2 B07
resource MOTOR 1 B08
save

In order to change VTX settings in OSD, you also need to load this VTX table file in the video transmitter tab: download VTX Table.

PID Tune

You will also need to retune the Moblite6 and Moblite7 (PID, rates and filters), stock tune flies terrible. I am still working on this, but if you have any good tune you want to share, let us know in the comment! Thanks!

Revert Back to Original Firmware

Stock Betaflight firmware is 3.5.7, but it’s no longer available in the list in the firmware flasher. The oldest firmware is 4.0.5, I tried that and it seems to also worked fine. CLI dump can be found here.

Leave a Comment

By using this form, you agree with the storage and handling of your data by this website. Note that all comments are held for moderation before appearing.

6 comments

Thomas 5th July 2021 - 10:42 pm

I flashed the latest betaflight version on my moblite7 and everything works fine apart from: I cannot change any of my VTX settings. My VTX changes get saved and I see them, but they don’t take any effect, the VTX channel and band stay on default. Any ideas what to do? I loaded the VTX table, set the UART, and the channel frequency shows correctly based on band and channel, but the VTX broadcasts on a different channel. I can see the image on the “wrong” channel, but I cannot change it. Thank you for any tips!!!!

Reply
Oscar 6th July 2021 - 12:00 am

download and load this VTX table in the video transmitter tab: happymodel.cn/wp-content/uploads/2019/10/BTFL_vtxtable_20191028_104831.zip

Reply
Thomas Blumer 6th July 2021 - 5:57 am

Dear Oscar,
I cannot thank you enough!!!!! I loaded a Jason file yesterday without success but the file you provided worked. I downloaded the file. went to Betaflight, loaded the Jason file from the VTX tab. I changed the band and channel and then set it back to my previous setting and it worked! Thank you so much!!!! In addition, your article above save me a lot of time as well, especially the motor reconfiguration! I sincerely hope I can return the favor in the future one way or another,
Cheers, Thomas

Reply
matti 3rd July 2021 - 7:34 am

Hey Oscar, check out this website for the tune:
https://betaflight.de/docs/tuning-beispiele/tuning-beispiele/happymodel-moblite6/

It’s German, but there is a language selector at the bottom of the page.

Link to the diff all for the mobilte6: https://1drv.ms/f/s!AqLnXyWYA2B74APhIFLfFXkRzNHO

Flys great, but Emuflight handles bounces against furniture and walls better. I hate to have to admit that.

Happy flying!

Reply
MeowKat346 3rd July 2021 - 1:50 am

Thank you Oscar. On a slightly different note, is it worthwhile setting up RPM filtering on these little quads?

Reply
Oscar 3rd July 2021 - 1:53 am

Not really, it flies awesome without RPM filter or higher PWM frequency. Some people actually mess up their quad somehow flashing the ESC. So I personally wouldn’t bother with it.

Reply